Pidgin-plus con gradienti

Ecco i gradienti all'opera! :-)
Ecco i gradienti all'opera! :-)

Un’immagine vale più di 1000 parole, e quindi ecco il frutto dei miei sforzi di programmazione di oggi pomeriggio :-)

Siccome l’autore del plugin pidgin-plus non si sente da un po’, ho deciso di prendere in mano il codice e di implementare questa caratteristica assente ormai da parecchio :-)

Known issues

Ci sono alcune “serie di sfortunati eventi” che non funzionano, eccone alcune:

  • gradienti con all’interno dei caratteri come questi: <, lettere accentate (èòàìù), caratteri strani (✿, ♫…) corretto nella versione 0.2.0.
  • a volte anche se contengono delle parentesi quadre.

Ovviamente spero di riuscire a risolvere il tutto al più presto :-) ma dovrebbe funzionare nel 90% dei casi.

Dove trovare il tutto

Per il codice e tutte le cose di sviluppo vi mando sul repository su GitHub, mentre per chi non si vuole sbattere può prendere il pacchetto .deb dalla pagina del mio repository, scegliendo l’architettura preferita. (chi ha già il mio repository attivo, basta che faccia un aggiornamento e si troverà questa versione aggiornata).

Per favore fate parecchi test e ditemi con quali pattern (nick) non funziona a dovere, incollandomeli qui nei commenti.

99 pensieri su “Pidgin-plus con gradienti”

  1. @frasten: Ora che il signal è incluso nell’mtn, puoi rendere disponibile su google code/sf il plugin in modo tale da dargli visibilità ed iniziare a pubblicizzarlo e magari farlo linkare nella pagina ufficiale dei plugin third party di pidgin? Grazie :)


  2. Markuz:

    @frasten: Ora che il signal è incluso nell’mtn, puoi rendere disponibile su google code/sf il plugin in modo tale da dargli visibilità ed iniziare a pubblicizzarlo e magari farlo linkare nella pagina ufficiale dei plugin third party di pidgin? Grazie

    Assolutamente d’accordo!!! (Y)

  3. Ottengo questo errore e non posso attivare il complemento:

    Error: No hubo coincidencia en el número de versión ABI 2.7.x (necesitaba 2.6.x)\n
    Compruebe el sitio web del complemento para obtener una actualización.

    Errore: non vi era sovrapposizione nel numero di versione 2.7.x ABI (necessità 2.6.x) \ n
    Visitate il sito di complimento per un aggiornamento.

    Cosa posso fare?
    Ho famiglia italiana ma non parlo italiano… (thanks google translate :P)

  4. I use pidgin 2.6.6 and the default libpurple version from ubuntu lucid repositories. (I can’t tell you the exact version because I’m not home right now)
    And I got the plugin from your ppa, i downloaded the lucid package, this one:
    pidgin-plus (0.2.1+git20100109-904b7d57-1~frasten+lucid0) lucid

  5. Ottimo questo supporto, mi chiedevo se era possibile far sì che anche nelle notifiche e nella taskbar non comparissero i tag colore.
    Emesene rende possibile questa feature e mi chiedevo se, tu che te ne intendi, sapessi come fare :D

    Fammi sapere e, se hai voglia, dai un’occhiata al mio blog che trattiamo di argomenti molto simili :-D :-D

  6. Ciao! Prima di tutto, mi scuso per il mio scarso livello di italiano. 3 anni fa non ho alcun contatto con questa lingua, così mi aiuti con un traduttore: P
    Ho scaricato il addon della pagina “GitHub”, ma non riesco a vedere i colori nel nick con i tag che hanno · $ o {}. Non riesco a vedere il colore o tag nel “sub-nick” o “messaggio personale”. Sto usando Windows e Pidgin nella sua ultima versione.
    Grazie per il addon!

    http://a.imageshack.us/img30/3036/74752704.png

Lascia una risposta

L'indirizzo email non verrà pubblicato. I campi obbligatori sono contrassegnati *

È possibile utilizzare questi tag ed attributi XHTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>